Payment Options & Eligibility in Bold Subscriptions V2

In order for Bold Subscriptions to process subscription transactions on your store, you will need to have either Shopify Payments,  Authorize.net, or PayPal Express connected and activated in your Shopify store. Shopify currently does not integrate with other payment gateways for subscriptions orders. Other payment methods may become available in the future.

Other Express Payment Options like ShopPay, Apple Pay, Google Pay, or Amazon Pay can be used for one time orders but will not appear in the checkout for customers purchasing an order with a subscription in it. At this time, subscription orders can only be purchased via credit card.

Please visit Shopify Payments for steps that you can follow to setup and configure Shopify Payments on your store.

 Pro-Tip

Please note that this article only relates to Version 2 of Bold Subscriptions. If you have Version 1 installed to your store, please visit our Connect a Payment Gateway to Bold Subscriptions V1 article.

If you are unsure which version of Bold Subscriptions that you have currently installed, please visit our Comparison article for V1 & V2, here.

 


 

Eligibility

To make sure that your store is eligible to run the Bold Subscriptions V2 app:

  • Your store must use Shopify Payments, Authorize.net or PayPal Express. This is because Shopify creates a subscription contract, which allows us to reuse the payment method that the customer used. This is currently only compatible with these payment gateways.

    Note: The eligibility requirements for Shopify Payments is controlled by Shopify directly. If your store is receiving a message about it being ineligible - please contact Shopify for more information.

  • Customers can't use accelerated checkouts such as Amazon Pay, Apple Pay, Google Pay, Klarna, mollie iDEAL, Shop Pay, and Sofort to purchase subscriptions.
  • A Storefront API cannot be currently used to build your storefront. 
  • Must not have an existing subscription service. An existing subscription service may cause front end compatibility issues. 
Was this article helpful?
0 out of 0 found this helpful